
Saving UmRSA Data Files

First, calculate the Segment or Point migration on the Kinematics form of
the UmRSA software. The Segment or Point data showing the various
migration components can be saved by clicking the right mouse button
over the “Output Entry” icon in the Calculation Log at the bottom left of
the Kinematic Analysis form. If this is not visible, choose View >
Calculation Log from the Main Menu of the Kinematic Form. Choose
“Save” on the "Output Entry" to bring up the Save dialog box. Create a
folder to save the data files in. It does not matter what the filename is
because you can set RSA DataViewer to rename the file appropriately (it
uses the patient ID and examination) by checking the "Rename Files" box
before reading-in the data file. RSA DataViewer is able to distinguish
Point Motion and Segment Motion files automatically, and it will name the
files accordingly, using a prefix of Seg or Pt. To save time, each data file in
UmRSA can therefore be saved as a, b, c …etc. A single UmRSA data file
may contain the results from just one examination or from several
examinations – RSA DataViewer will read them in the same way. It does
not matter if there is a mixture of such files when multiple files are
selected.





Using RSA DataViewer

Read Data File

Select File > ReadDataFile from the Main Menu or click the
ReadDataFile button to bring up the Open File dialog box
Browse to find your data folder
To read a single file, double click on that file
To read a continuous series of files, select the first file, hold down
the Shift key and select the last file, then chose "Open"
To select several individual files, hold down the Control key whilst
selecting each file

The raw migration data from UmRSA is “signed” according to the same
axis system for all component migrations, whether they be for a prosthesis



on the patient's left or right side. However, RSA DataViewer has a default
setting which adjusts the signs of translations and rotations according to
the patient side (left or right). For instance, lateral translation on a left hip
or a right hip is given a positive value in both cases. This feature enables
medial-lateral or anterior-posterior or proximal-distal migrations of left
and right prostheses to be plotted on the same chart. The column names at
the top of each table represent positive directions. If you would like to
disable this feature, select Options in the Main Menu and uncheck the
“Side Signs” option before reading-in the data file. IT IS
RECOMMENDED THAT YOU DO NOT DISABLE THIS
FEATURE 

File Order

The data files are read into the tables in the same patient ID order that they
are selected from their folder (either singly or as a group). Normally, the
files in the folder are automatically arranged into alpha-numeric order by
Windows; so they should appear in the patient number order of the files
you selected. However, if you would like to change the order of the rows
when the data has been read into RSA DataViewer, simply left-click on the
left column of a row, hold the button down, and drag the row to the
required position in the table.


Saving and Opening a Data File

Once the data has been read into the Segment Motion or Point Motion
tables on the screen, the data can be saved as a text file.

Select "File > Save As" in the Main Menu to show
Browse to a suitable location or create a folder
Enter a file name and save the data

The data is saved as a text file with a ".tab" extension. To read the data
back into RSA DataViewer from a previously saved Table file, select "File
> Open" from the Main Menu or click the "Open File" button, and then
select the file. If the file is not visible in the "Open File" box, click the
drop-down "Files of Type" list and select, "Table". Be careful when doing
this because Segment Motion and Point Motion tables which do not
correspond (i.e. from different projects or measurement sets) can be
opened using this method.




The saved .tab file can be opened in other documents.

To open in MS Excel:


Open Excel
Select "Open" from the Main Menu of Excel
Double-click on the .tab file that you would like to open
Check the "tab delimited" box
Continue selecting "Next"

If you change the data once you have opened a table in Excel, save the
table as a text file. Please check the data file in a Word document to make
sure you have not introduced incorrect spacing (by, for instance
introducing an excessively large Patient ID number). Note that Excel may
reformat symbols (e.g. +/-) when saved as a text file. You can correct this
in a Word document. To open this file, select "Text" in the "Files of Type"
list box.


To remove data from both tables, select File->New or click the New File
Button.


Each table can be expanded (dropped down) to show more data. To expand
the Segment Motion table, select the Segment Motion tab at the top of the
tables (it will highlight) then RIGHT click on the tab. Right clicking again
causes the table to compress.


Setting Names for Individual Point Markers


Each individual Point can be named, e.g. Shoulder, Tip, Head. To do this:

Select Options > More Options on the Main Menu to enter names in
the Set Point Names box
In the box on the left hand side, landmark points are numbered
consecutively (1, 2, 3 …) in the order that they appear on the
UmRSA data sheet (which is the same order that they appear on the
RSA DataViewer Points Motion page). Select the first point in the
box
The cursor will jump to the Name box on the right. Enter the name
of the point (keep this short)
Press the Return (Enter) key on the keyboard



The first number in the left hand box is replaced by the name you
entered, and the number below it is automatically selected. Enter the
name for the second point
Repeat this procedure until all points have been named
To save these names for subsequent sessions, check the Save As
Default Names box
Finally, click Accept

All the point column names in the Point Motion page will be changed and
all titles in the Point Motion charts will include these names. Select
landmark point in the "Select Points to Draw" box in the left panel.


Mean/Median and Standard Deviation/Quartiles

The bottom two rows of the Segment Motion and Point Motion pages are
reserved for the mean/median and the mean ±SD or median ±quartile. You
have an option to display the Mean Absolute values or the standard Mean
(of +/- values). You can also choose 1SD, 2SD or 3SD from the mean (1st
quartile, 3rd quartile, or 95th percentile from the median) to be displayed
in the bottom row.

Note: although the SD/quartile/percentile values are joined by a line in the
charts, they are only valid at each of the plotted points. An SD graph
should strictly appear above and below the Mean graph, but RSA
DataViewer is configured to create an SD line on the side of the horizontal
axis where most of the data values occur.If you wish to display the other
line (alone), select the Change SD Sign box.

The values are calculated from each column of data above the
Mean/Median row.


Sometimes (e.g when there is an outlier), you might want to remove a
particular patient’s migrations from the Mean/median and SD/quartile
graphs and to plot that patient’s graphs separately.

To do this:

Left-click on the left cell of that patient’s data row
While holding the left mouse button down, drag the row below the
SD row

The Mean and SD (or Median and quartile) values are then re-calculated
for all the rows above the Mean row. You can do this for any number of



patient rows. NOTE: you cannot drag the Mean/Median and SD/Quartile
rows.


Note: there are different methods of calculating quantiles (e.g. median,
quartile). The method used by RSA DataViewer is described by Bland (An
Introduction to Medical Statistics, 3rd Edition, Oxford University Press):-


The number i of the q quantile (e.g. q = 0.5 for median, 0.25 for 1st
quartile) for n data is given by i = q(n+1) if i is an integer (the value Xi at i
is then the quantile). If i is not an integer then, if j is the integer part of i,
the quantile lies between the Xj and Xj+1 values and is given by: Xj +
(Xj+1 - Xj)*(i - j).

You can check the calculation of mean, median etc (using a few data
rows) to satisfy yourself that the result is what you want before
proceeding to use RSA DataViewer.


Charts

Displaying Graphs


To display graphs of the results of a particular patient, select a row

corresponding to that patient using the left mouse button. Each chart will
draw the respective migration component for that patient.




To display multiple graphs for a consecutive series of patients, select the
row for the first patient in that series, then hold down the Shift key whilst
clicking the last row in the series.




To display multiple graphs from a non-consecutive series of patients, select
the row for the first patient in the series, then hold down the Control key
whilst selecting the other rows that you require. NOTE: Plane charts will
display a maximum of 30 graphs, the other charts will display a maximum
of 10 graphs (to avoid clutter and enable display of legends).




Migration Rate



The default setting for RSA DataViewer is to display migration graphs. To



display graphs of migration rate, check the Show Rate box in the left
panel. Each point on a graph then represents the migration rate in the
preceding examination interval. Note: the tabulated values in each row do
not change when the migration rate is calculated and displayed in each
chart. However, the bottom two rows of the table show the mean/median
and SD/quartile migration rates for each column. If data is missing in one
of the cells of a column, the rate for that cell is calculated by interpolating
between previous and subsequent filled cells in the row before it is used in
the calculation of the mean (median) and SD (quartile) of that
column.Only the mean +/- value can be calculated (not the mean absolute)
because +ve and -ve rates may occur in each column - reflecting temporary
changes in migration due to measurement error. By using +/- Mean, these
error difference are averaged out.


Point Motion Charts

Since there will be several possible landmark points on the prosthesis (e.g.
femoral head, stem shoulder, stem tip) these can be displayed separately or
all together in the charts. The default setting is to display the first data set
appearing in the data file (e.g. shoulder). To change to a different point,
select the point in the "Select Points to Draw" box in the left panel. When
a single point is selected, up to 10 patient graphs (10 rows) can be
displayed in the charts. If the "Select All" box is checked, graphs for all of
the points will be displayed in each chart - but just for a single patient.
Graphs for multiple patients cannot be displayed when more than one
point is selected.


Plane Migration Charts

Migration in the transverse (XZ), coronal (XY) or sagittal (YZ) plane is
the resultant migration vector component in that plane. A maximum of 50
patient rows can be selected to be displayed in each of these charts. The
migrations displayed in the charts are for one examination. The
examination (time) can be changed by selection from the Plane Chart
Exam list in the left panel. The mean value (scalar magnitude) of the plane
migration vectors for all the selected patients is displayed at the bottom of
the charts (together with the number of selected patients). Percentages
shown above and below the four quadrants refer to the proportion of
migration vectors in each of the quadrants. This is a simple method of
summarising the direction of migrations in the transverse plane. The
“mean” direction, calculated from the mean X and mean Z values (for



instance) has been reported in some publications, but this is incorrect.


Chart Features

To display the data value corresponding to a particular point on a graph,
set the cursor cross-wire on that point and Left Click.


To change the last examination on the horizontal axes, click the Chart Last
Month drop-down list on the left panel.


To change the chart colours/gradient, select More Options in the chart
menu and click on the coloured squares to show the colour dialog box.
Click Save to save the colours for the next session. Retrieve the default
blue colours by checking the Default Colour box - then save if needed next
time. The most recent colours remain on the square buttons, so by
unchecking Default Colours and closing the More Options box, the charts
are repainted with the previous colours. 

The scale of the vertical axis is normally set automatically and it changes
according to the largest migration of all of the graphs that are plotted on
the chart. However, this adaptation of the scale can be prevented by
checking the "Freeze Scales" check box in the left panel. Thus, if you want
to see how a group of patients with low migrations compares to a
relatively large mean, first select the Mean row (to display the Mean
graph), then check "Freeze Scales", then select the group of graphs that
you want to compare to the Mean.


The top 5 migrations in a data column are listed by right clicking on the
appropriate chart for that column and selecting Top 5. A list appears
showing the top 5 migrations in that column from the top data row to the
one above the Mean/Median data row. Calculation is performed on the
column in the last examination (or last but one examination if the data cell
is empty). The Top 5 migration rates can also be listed in a similar
way.Calculation of the Top 5 migrations/rates is carried out using the
absolute values of the migrations in each data cell of the column. If a row
is dragged below the SD row, that row will not be included in the Top 5
calculation.


Dashed lines showing the measurement error (derived from your double-
examination measurements) can be included on all charts by checking
ShowErrorBox in Main Menu > Charts before selecting the rows. The



default setting is 0.1 mm.

To input measurement errors derived from your double examination
measurements:


Select Options> More Options from the Main Menu
In the Error Box section, enter your double examination errors in the
appropriate boxes

Values higher than 1.0 mm will not be accepted. Your entered error values
can be saved as default settings which will be automatically loaded at
subsequent sessions with RSA DataViewer. However, if you wish to re-set
the Default settings, check the Use Default Settings box before reading in
the data files.


Copy and Paste Charts

Right Click over the chart and make a selection from the drop-down menu.
Once copied, these charts can be pasted into software such as MS Office
(e.g. Word, Excel) as a Windows Metafile. If several charts are copied
consecutively, use the Clipboard (Edit Menu in MS Word) to select some
or all of them for pasting.


If you wish to present hard copies of rows of charts, open a new Word
document and adjust the page set-up to Landscape with narrow margins.
Click on the document and then select Paste (or Paste All in the Clipboard
tool).


Using the Copy and Paste technique for hard copies is simpler and much
better than printing charts because it enables you to arrange the position
and size of each chart on the Word document (click the pasted chart and
drag the corners to expand its size).


The chart background and the graphs will retain their original colours
when pasted. However, in some cases (e.g. presentation in a publication)
you might want to have a white background and black graphs - in which
case the legend will be superfluous. In addition, you might want to remove
the title at the top of the chart. You can change/remove each of these
features by checking or unchecking the appropriate item in Main Menu >
Charts.


Once pasted, you can superimpose text etc. on the chart in the usual way,



i.e. use the Drawing ToolBar in Word to create text and graphic objects.
(Select all the items as well as the chart, then Right Click and select
Group, before moving the chart.)


Visit Web Site of: OrthoMechanics Research


http://www.orthomech.co.uk/

